improved-autocomplete-php

improved-autocomplete-php is a PHP provider for autocomplete+


License
MIT
Install
apm install improved-autocomplete-php@1.1.1

Documentation

improved-autocomplete-php package

An improved Atom PHP autocompleter for autocomplete-plus

@shenmin - Added the support for all function names in the same folder with editing file.

Demo

Requirements:

  • Atom autocomplete-plus package (bundled with Atom)
  • Now is mandatory have PHP in the environment PATH

Installation

  • apm install improved-autocomplete-php
  • or install through Atom's UI

Thanks to:

  • @azakur4 - I forked from here
  • @amp343 - Add snippets to php internal functions
  • @fbereche - Help me with some ideas in the new way to get autocomplete