AlibabacloudEndpointUtil

Alibaba Cloud Endpoint Util Library for Swift SDK


License
Apache-2.0
Install
pod try AlibabacloudEndpointUtil

Documentation

English | 简体中文

Alibaba Cloud Endpoint Util for Swift

Requirements

  • iOS 13.3+ / macOS 10.15+
  • Xcode 11.3+
  • Swift 5.6

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. For usage and installation instructions, visit their website. To integrate AlibabacloudEndpointUtil into your Xcode project using CocoaPods, specify it in your Podfile:

pod 'AlibabacloudEndpointUtil', '~> 1.0.0'

Carthage

To integrate AlibabacloudEndpointUtil into your Xcode project using Carthage, specify it in your Cartfile:

github "alibabacloud-sdk-swift/endpoint-util" "1.0.0"

Swift Package Manager

To integrate AlibabacloudEndpointUtil into your Xcode project using Swift Package Manager , adding AlibabacloudEndpointUtil to the dependencies value of your Package.swift.

dependencies: [
    .package(url: "https://github.com/alibabacloud-sdk-swift/endpoint-util.git", from: "1.0.0")
]

In addition, you also need to add "AlibabacloudEndpointUtil" to the dependencies of the target, as follows:

.target(
    name: "<your-project-name>",
    dependencies: [
        "AlibabacloudEndpointUtil",
    ])

Issues

Opening an Issue, Issues not conforming to the guidelines may be closed immediately.

Changelog

Detailed changes for each release are documented in the release notes.

References

License

Apache-2.0

Copyright (c) 2009-present, Alibaba Cloud All rights reserved.