forcedotcom/sfdx-dev-packages


License: BSD-3-Clause

Language: TypeScript


Development Packages for Salesforce

CircleCI

Introduction

This repository contains packages that help with development and configuration of Salesforce typescript projects.

Getting Started

If you are interested in contributing, please take a look at the CONTRIBUTING guide.

If you are interested in building these packages locally, please take a look at the DEVELOPING doc.

Packages

Currently, we have the following packages:

@salesforce/dev-config - Common configuration files

@salesforce/dev-scripts - Common dev scripts, such as clean, compile, lint, test, and more

@salesforce/ts-types - Common typescript types and helpers

@salesforce/kit - Common utility methods and designed patterns

@salesforce/ts-sinon - TypeScript-friendly helpers for testing with Sinon

@salesforce/lazy-require - CommonJS require interceptor that lazily loads packages via proxy

@salesforce/require-analytics - Generates simple runtime module loading diagnostic analytics

Project Statistics

Sourcerank 10
Repository Size 2.24 MB
Stars 9
Forks 2
Watchers 15
Open issues 2
Dependencies 893
Contributors 4
Tags 196
Created
Last updated
Last pushed

Top Contributors See all

Thomas Dvornik Bob Bergman tnoonan-salesforce David

Packages Referencing this Repo

@salesforce/ts-sinon
TypeScript helpers for Sinon
Latest release 1.1.1 - Updated - 9 stars
@salesforce/ts-types
Types and related utilities for TypeScript
Latest release 1.2.1 - Updated - 9 stars
@salesforce/dev-scripts
A set of standard package.json scripts for Salesforce projects.
Latest release 0.4.1 - Updated - 9 stars
@salesforce/kit
Commonly needed utilities for TypeScript and JavaScript
Latest release 1.2.1 - Updated - 9 stars
@salesforce/dev-config
A set of standard typescript config and tslint options for Salesforce projects.
Latest release 1.5.0 - Updated - 9 stars
@salesforce/lazy-require
Lazily load npm packages
Latest release 0.2.1 - Updated - 9 stars
@salesforce/require-analytics
Simple CommonJS require analytics
Latest release 0.7.1 - Updated - 9 stars

Recent Tags See all

@salesforce/ts-types@1.2.1 August 30, 2019
@salesforce/ts-sinon@1.1.1 August 30, 2019
@salesforce/require-analytics@0.7.1 August 30, 2019
@salesforce/lazy-require@0.2.1 August 30, 2019
@salesforce/lazy-require@0.2.1 August 30, 2019
@salesforce/kit@1.2.1 August 30, 2019
@salesforce/dev-scripts@0.4.1 August 30, 2019
@salesforce/dev-scripts@0.4.1 August 30, 2019
@salesforce/ts-types@1.2.0 July 17, 2019
@salesforce/ts-types@1.2.0 July 17, 2019
@salesforce/ts-sinon@1.1.0 July 17, 2019
@salesforce/ts-sinon@1.1.0 July 17, 2019
@salesforce/require-analytics@0.7.0 July 17, 2019
@salesforce/lazy-require@0.2.0 July 17, 2019
@salesforce/lazy-require@0.2.0 July 17, 2019

Something wrong with this page? Make a suggestion

Last synced: 2019-08-30 12:00:57 UTC

Login to resync this repository