johnpryan/date_utils


Dart Library for working with DateTimes.

License: BSD-3-Clause

Language: Dart


date_utils

Build Status

A Dart library to manipulate DateTimes. Useful for creating calendar functionality.

Example

See Packages:

Tzolkin Web Calendar

flutter_calendar

Usage

  1. Add the following to your pubspec.yaml:
dev_dependencies:
    date_utils: ^0.0.1
  1. Run pub install

  2. Import the package in your Dart code

import 'package:date_utils/date_utils.dart';
  1. Use the Utils class.
// example
var date = new DateTime(2017, 3);
var lastDay = Utils.lastDayOfMonth(date);
print(lastDay.day);
// => 31

Project Statistics

Sourcerank 10
Repository Size 1.45 MB
Stars 44
Forks 35
Watchers 4
Open issues 8
Dependencies 2
Contributors 3
Tags 0
Created
Last updated
Last pushed

Top Contributors See all

John Ryan Eric Windmill Rody Davis

Packages Referencing this Repo

date_utils
A Dart library for manipulating DateTimes.
Latest release 0.1.0 - Updated - 44 stars

Something wrong with this page? Make a suggestion

Last synced: 2019-12-20 17:46:49 UTC

Login to resync this repository