lopatnov/rollup-plugin-uglify


A rollup plugin to minify javascript with UglifyJS

https://lopatnov.github.io/rollup-plugin-uglify/

License: Apache-2.0

Language: JavaScript

Keywords: javascript, rollup-plugin, terser, typescript, uglify


@lopatnov/rollup-plugin-uglify

NPM version License Twitter

A rollup plugin to minify javascript

Install

https://nodei.co/npm/@lopatnov/rollup-plugin-uglify.png?downloads=true&downloadRank=true&stars=true

npm install @lopatnov/rollup-plugin-uglify

Import package to the project

TypeScript

import uglify from "@lopatnov/rollup-plugin-uglify";

JavaScript

var uglify = require("@lopatnov/rollup-plugin-uglify");

How to use plugin

File rollup.config.ts

export default {
  //...
  plugins: [
    //...
    uglify()
  ]
};

Rights and Agreements

License Apache-2.0

Copyright 2019 Oleksandr Lopatnov

Project Statistics

Sourcerank 3
Repository Size 207 KB
Stars 0
Forks 0
Watchers 1
Open issues 0
Dependencies 444
Contributors 1
Tags 7
Created
Last updated
Last pushed

Top Contributors See all

Oleksandr

Packages Referencing this Repo

@lopatnov/rollup-plugin-uglify
Rollup plugin. Javascript code minifier
Latest release 1.2.0 - Updated

Recent Tags See all

1.2.1 December 07, 2019
1.2.0 December 07, 2019
1.1.0 December 07, 2019
1.0.2 December 07, 2019
1.0.1 December 07, 2019
1.0.1 December 07, 2019
1.0.0 December 07, 2019

Something wrong with this page? Make a suggestion

Last synced: 2019-12-07 12:16:45 UTC

Login to resync this repository