segiddins/cocoapods-dependencies


Shows a project's CocoaPods dependency graph

License: MIT

Language: Ruby


cocoapods-dependencies

Gem Version Code Climate

Shows a project's CocoaPod dependency graph.

Installation

$ [sudo] gem install cocoapods-dependencies

Usage

$ pod dependencies [PODSPEC] [--graphviz] [--image]

Use the --graphviz option to generate <podspec name>.gv or Podfile.gv containing the dependency graph in graphviz format.

Use the --image option to generate <podspec name>.png or Podfile.png containing a rendering of the dependency graph.

[!] Note that for either graphviz or image output, GraphViz must be installed and dot must be accessible via $PATH.

Project Statistics

Sourcerank 8
Repository Size 39.1 KB
Stars 107
Forks 13
Watchers 2
Open issues 2
Dependencies 35
Contributors 6
Tags 16
Created
Last updated
Last pushed

Top Contributors See all

Samuel Giddins Brian Partridge Bogdan Poplauschi Steffen Matthischke Stuart Kent Dimitris Koutsogiorgas

Packages Referencing this Repo

cocoapods-dependencies
Shows a project's CocoaPods dependency graph.
Latest release 1.3.0 - Updated - 107 stars

Recent Tags See all

1.3.0 August 16, 2018
1.2.0 July 16, 2018
v1.1.0 October 20, 2017
v1.0.0 October 04, 2016
v1.0.0.beta.1 January 15, 2016
v0.5.2 November 27, 2015
v0.5.1 October 12, 2015
v0.5.0 July 03, 2015
v0.4.1 March 25, 2015
v0.4.0 November 19, 2014
v0.3.2 November 08, 2014
v0.3.1 October 21, 2014
v0.3.0 October 17, 2014
v0.2.1 October 09, 2014
v0.2.0 October 09, 2014

Interesting Forks See all

b-ray/cocoapods-dependencies
Shows a project's CocoaPods dependency graph
Ruby - MIT - Last pushed - 4 stars - 1 forks

Something wrong with this page? Make a suggestion

Last synced: 2018-08-16 06:00:43 UTC

Login to resync this repository