mpivaa/pagarme-nodejs


test repo

http://premailer.dialect.ca/

License: BSD-3-Clause

Language: Ruby


PagarMe - node.js

NÃO UTILIZE ESTE MODULO - DON'T USE THIS MODULE

Installation

npm install git+https://github.com/mpivaa/pagarme-nodejs.git

Usage

PagarMe = require('pagarme')
PagarMe.api_key = "ak_test_N7DGOazupaDE1SvVjCmP3HVqxiF9ne";
transaction = new PagarMe.Transaction;

//Error handling and callbacks
transaction.http_error = function (e) { console.log(e) }
transaction.api_error = function (e) { console.log(e) }
transaction.paid = function() { console.log('paid') }
transaction.refused = function () { console.log(this.refuse_reason) }

//Card info
transaction.card_number = "4901720080344448"
transaction.card_holder_name = "Jose da Silva"
transaction.card_expiration_date = "1015"
transaction.card_cvv = "314"
transaction.amount = 1000

transaction.charge();

Project Statistics

Sourcerank 5
Repository Size 1.88 MB
Stars 0
Forks 0
Watchers 4
Open issues 0
Dependencies 4
Contributors 8
Tags 8
Created
Last updated

Top Contributors See all

Alex Dunae Aaron Eisenberger ju1ius Ian Leitch Michael Guterl Mikael Fridh Akzhan Abdulin David Reese

Recent Tags See all

1.7.0 March 31, 2011
1.6.2 November 22, 2010
1.6.0 November 17, 2010
1.6.1 November 17, 2010
1.5.7 November 05, 2010
1.5.6 November 04, 2010
1.5.4 December 09, 2009
1.5.3 December 03, 2009

Something wrong with this page? Make a suggestion

Last synced: 2018-12-15 00:00:10 UTC

Login to resync this repository