@0x/contracts-erc20

Token contracts used by 0x protocol


License
Apache-2.0
Install
npm install @0x/contracts-erc20@3.3.32

Documentation


0x is an open protocol that facilitates trustless, low friction exchange of Ethereum-based assets. For more information on how it works, check out the 0x protocol specification.

This repository is a monorepo including the 0x protocol smart contracts and numerous developer tools. Each public sub-package is independently published to NPM.

CircleCI Coverage Status Discord License

Packages

Visit our developer portal for a comprehensive list of core & community maintained packages. All packages maintained with this monorepo are listed below.

Solidity Packages

These packages are all under development. See /contracts/README.md for a list of deployed packages.

Package Version Description
@0x/contracts-zero-ex npm The contracts used for settling trades within the protocol
@0x/contracts-erc20 npm Implementations of various ERC20 tokens
@0x/contracts-test-utils npm TypeScript/Javascript shared utilities used for testing contracts
@0x/contracts-utils npm Generic libraries and utilities used throughout all of the contracts

TypeScript/Javascript Packages

0x-specific packages

Package Version Description
@0x/asset-swapper npm Package used to find and create aggregated swaps
@0x/protocol-utils npm A set of utilities for generating, parsing, signing and validating 0x orders
@0x/contract-addresses npm A tiny utility library for getting known deployed contract addresses for a particular network.
@0x/contract-wrappers npm JS/TS wrappers for interacting with the 0x smart contracts
@0x/migrations npm Migration tool for deploying 0x smart contracts on private testnets
@0x/contract-artifacts npm 0x smart contract compilation artifacts

Usage

Node version 6.x or 8.x is required.

Most of the packages require additional typings for external dependencies. You can include those by prepending the @0x/typescript-typings package to your typeRoots config.

"typeRoots": ["node_modules/@0x/typescript-typings/types", "node_modules/@types"],

Contributing

We strongly recommend that the community help us make improvements and determine the future direction of the protocol. To report bugs within this package, please create an issue in this repository.

Read our contribution guidelines.

Install dependencies

Make sure you are using Yarn v1.9.4. To install using brew:

brew install yarn@1.9.4

Then install dependencies

yarn install

Build

To build all packages:

yarn build

To build a specific package:

PKG=@0x/asset-swapper yarn build

To build all contracts packages:

yarn build:contracts

Watch

To re-build all packages on change:

yarn watch

To watch a specific package and all it's dependent packages:

PKG=[NPM_PACKAGE_NAME] yarn watch

e.g
PKG=@0x/asset-swapper yarn watch

Clean

Clean all packages:

yarn clean

Clean a specific package

PKG=@0x/asset-swapper yarn clean

Rebuild

To re-build (clean & build) all packages:

yarn rebuild

To re-build (clean & build) a specific package & it's deps:

PKG=@0x/asset-swapper yarn rebuild

Lint

Lint all packages:

yarn lint

Lint a specific package:

PKG=@0x/asset-swapper yarn lint

Run Tests

Run all tests:

yarn test

Run a specific package's test:

PKG=@0x/asset-swapper yarn test

Run all contracts packages tests:

yarn test:contracts