@lapidist/components

Lapidist components


Keywords
react, components, component library, styled components, lapidist, component-library, typescript
License
MIT
Install
npm install @lapidist/components@6.17.1

Documentation

Lapidist Logo

@lapidist/components

Opinionated React UI library, built with styled-components and TypeScript.

npm bundle size (scoped) npm GitHub package.json dependency version (dev dep on branch) GitHub package.json dependency version (dev dep on branch) codecov Maintainability Node GitHub Issues GitHub GitHub Release Build Status

Getting Started

@lapidist/components is available as an npm package.

See https://components.lapidist.net for the full documentation.

Installation

// via npm
npm install @lapidist/components styled-components

// or via yarn
yarn add @lapidist/components styled-components

Usage

Ensure you wrap your application with the <ThemeProvider> component. Here is a quick example to get you started:

import React from 'react';
import ReactDOM from 'react-dom';
import { ThemeProvider, Text } from '@lapidist/components';

const App = () => (
    <ThemeProvider>
        <Text>Hello world</Text>
    </ThemeProvider>
);

ReactDOM.render(<App />, document.querySelector('#app'));

Philosophy

  • Quality over quantity: a small library of well-designed components is preferable to many poor components.
  • Constraints are good: consistency takes precedence over configurability.
  • Modern: we don't support older browsers.

License

@lapidist/components is licensed under the MIT license. See LICENSE for the full text.