@sanv/eslint-config-typescript

Eslint Configuration with Typescript Support


Keywords
eslint-config, eslint, config, react eslint config, react eslint, react typescript config, typescript config, eslint jest config, eslint jest, eslint stories config, eslint stories, eslint storybook
License
ISC
Install
npm install @sanv/eslint-config-typescript@2.1.1

Documentation

ESLint Configs

JavaScript

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-base" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-base"
}

React

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-react" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-react"
}

TypeScript

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-typescript" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-typescript"
}

React + TypeScript

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-react-typescript" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-react-typescript"
}

Storybook

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-stories" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-stories"
}

Storybook with TypeScript

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-stories-typescript" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-stories-typescript"
}

Tests

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-tests" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-tests"
}

Tests with TypeScript

  1. Install the correct version of package, which are listed by the command:
npm install "@sanv/eslint-config-tests-typescript" --save-dev
  1. Add next line to your .eslintrc.js:
{
  "extends": "@sanv/eslint-config-tests-typescript"
}