Tronprotocol Wallet API wrapper


Keywords
tron, tron-protocol
License
GPL-3.0
Install
npm install @tronprotocol/wallet-api@0.0.37

Documentation

node-wallet-api

Node.js Wallet API for the Tron Protocol

How to UseLinksWikiCommunity

How to use

Requirements

  • Node v9.8.0

Running tests

Running the tests requires an active wallet-cli application. Check out to the readme to get it up and running.

When there is a running wallet-cli application use npm to run the tests

> npm test

Usage

Install the package

> npm install @tronprotocol/wallet-api

Use the HTTP Client

import {HttpClient} from "@tronprotocol/wallet-api";

const Client = new HttpClient();

let latestBlock = await Client.getLatestBlock();

Community

Links

Projects