babel-preset-minify-es2015

A set of babel plugins for minification of ES2015 code without transpilation to ES5


Keywords
babel, babel-preset, es2015, minification
License
ISC
Install
npm install babel-preset-minify-es2015@0.0.3

Documentation

babel-preset-minify-es2015

Minifty ES2015 code without needing transpilation to ES5.

Install

$ npm install --save-dev babel-preset-minify-es2015

Usage

Via .babelrc (Recommended)

.babelrc

{
  "presets": ["minify-es2015"]
}

Via CLI

$ babel script.js --presets minify-es2015 

Via Node API

require('babel-core').transform('code', {
  presets: ['minify-es2015']
});