Thrift client for browser


Keywords
thrift, webpack, browserify
License
Apache-2.0
Install
npm install browser-thrift@0.11.0

Documentation

browser-thrift

Patched version of Apache Thrift Node.js library to work with Webpack / Browserify.

Usage

It is necessary to replace all require('thrift') with require('browser-thrift') in the thrift generated files. You may use sed for that:

for f in <gen_folder>/*; do
  sed -i '' -e "s/'thrift'/'browser-thrift'/" "$f"
done