eslint-plugin-censor

The plugin will prevent you from using swear pejoratives and abuse words


Keywords
eslint, bad, words, abuse, swear, pejoratives, eslint-plugin
License
MIT
Install
npm install eslint-plugin-censor@1.5.1

Documentation

eslint-plugin-censor

eslint-plugin-censor The plugin will prevent you from using swear pejoratives and abuse words.

Version Dependencies Vulnerabilities Build Status Coverage Status License

Table of Contents

Requirements

To use library you need to have node and npm installed in your machine:

  • node 6.0+
  • npm 3.0+

Installation

To install the library run following command

  npm i --save eslint-plugin-censor

Usage

Sources

Contribute

Make the changes to the code and tests and then commit to your branch. Be sure to follow the commit message conventions.

Commit message summaries must follow this basic format:

  Tag: Message (fixes #1234)

The Tag is one of the following:

  • Fix - for a bug fix.
  • Update - for a backwards-compatible enhancement.
  • Breaking - for a backwards-incompatible enhancement.
  • Docs - changes to documentation only.
  • Build - changes to build process only.
  • New - implemented a new feature.
  • Upgrade - for a dependency upgrade.
  • Chore - for tests, refactor, style, etc.

The message summary should be a one-sentence description of the change. The issue number should be mentioned at the end.