Documentation

Pinejs Client

This module provides the core layer for javascript interface for the pinejs API, there are multiple builds you can use, to set the version globally use @balena/es-version, eg:

// Must be set before the first require
require('@balena/es-version').set('es2015') // We support exact matches on es2015 (default) and es2018, see https://github.com/balena-io-modules/balena-es-version for a full list of possible versions
require('pinejs-client-core') // requires the version set above

or to force a specific version overriding the default (not recommended) you can use

require('pinejs-client-core/es2015') // es2015/es6
require('pinejs-client-core/es2018') // es2018

For specific backends check out