Find and update outdated packages.


Keywords
build-tools, dependencies, javascript, nodejs, npm, outdated, sake
License
BSD-3-Clause
Install
npm install sake-outdated@0.4.4

Documentation

sake-outdated

npm build dependencies downloads license chat

Add outdated and outdated:update tasks to your Sakefile. Updates Node dependencies, package.json, lock files and automatically generates pretty git commits.

Features

  • Update dependencies in package.json automatically
  • Generate nicely formatted corresponding git commit
  • Automatically commit changes and corresponding updates to package.json and lock files
  • Integrates with npm and yarn

Install

$ npm install sake-outdated --save-dev

Usage

use('sake-outdated', {
    commit: true,       // automatically commit changes to git
    ignore: ['jquery'], // optionally ignore packages
})

License

BSD