wp-content-framework/update

Wordpress content framework


Keywords
framework, wordpress
License
GPL-2.0+

Documentation

WP Content Framework (Update module)

License: GPL v2+ PHP: >=5.6 WordPress: >=3.9.3

WP Content Framework のモジュールです。

要件

  • PHP 5.6 以上
  • WordPress 3.9.3 以上

インストール

composer require wp-content-framework/update

依存モジュール

基本設定

  • configs/config.php
設定値 説明
readme_file_check_url Upgrade Noticeを取得するreadmeファイルのURLを設定
upgrade_notice_cache_duration 更新情報をキャッシュする期間(秒) [default = 86400]
upgrade_notice_empty_cache_duration 更新情報が空であったことをキャッシュする期間(秒) [default = 600]

Author

GitHub (Technote)
Blog