djangorestframework-utils

Utilities for Django REST Framework


License
BSD-3-Clause
Install
pip install djangorestframework-utils==0.0.1

Documentation

djangorestframework-utils

build-status-image pypi-version

Overview

Utilities for Django REST Framework

Requirements

  • Python (2.7, 3.3, 3.4)
  • Django (1.6, 1.7, 1.8)
  • Django REST Framework (3.0, 3.1)

Installation

Install using pip

$ pip install djangorestframework-utils

Features

  • VerboseMetadata (which is more verbose and not ambiguous like SimpleMetadata)
  • modelserializer_factory

VerboseMetadata features

  • Add field's allow_null and default properties
  • Include pattern property for RegexField
  • Include max_digits and decimal_places properties for DecimalField

For further information, see the [documentation](http://benzid_wael.github.io/djangorestframework-utils/docs).

Example

TODO: Write example.

Documentation & Support

Full documentation for the project is available at `docs`_.

You may also want to follow the author on Twitter.

Bitdeli badge