Python bindings to ViZDoom


License
MIT
Install
pip install doom-py==0.0.15

Documentation

doom_py

Build Status

Python wrappers for ViZDoom. Contains a modified version of the bleeding-edge ViZDoom source code.

Requirements

  • CMake 3.0+
  • Make
  • GCC 4.6+
  • Boost Libraries
  • SDL 2.0.2
  • Python with Numpy

To install dependencies on Ubuntu, type

apt-get install -y python-numpy cmake zlib1g-dev libjpeg-dev libboost-all-dev gcc libsdl2-dev wget unzip