libfluent

Fluent makes it easy and fast to build beautiful mobile apps


Keywords
android, desktop, python, sdl
License
MIT
Install
pip install libfluent==1.0.0b4

Documentation

Fluent – Simple and powerful multi-platform development framework.

Example

Here is the basic Hello, world code example:

from fluent.essential import *  # Importing library


# Calling launch method
launch(
    # Setting target to Text widget
    target=Text(
        text='Hello, Fluent',  # Setting text to the widget
        color=color.white  # Setting color to the widget
    )  # Text
)  # launch

Features

Here is the most featured features:

  • Hot reload
  • Platform independent
  • Easy-to-use
  • All is a widget concept

Installation

The simplest installation way is using pip. You can install the latest stable release by executing following command:

$ pip install libfluent

Also, you need to have sdl2-gfx and sdl2-ttf library. You can download it here and here. Unpack that, and execute following commands to compile and install the library:

$ ./configure
$ make
$ make install

Or, in the latest release we added automated installation script that installs the latest version from our repository and installs all SDL additional packages. Execute that using:

$ sh bin/install.sh

Requirements

You need to compile and install sdl2-gfx and sdl2-ttf libraries for rendering advanced primitive shapes.