pydotmailer

A reusable python module for driving the dotMailer API


License
Other
Install
pip install pydotmailer

Documentation

dotMailer Python API Wrapper 0.1
-------------------------------------------------------------------------------
This folder got from Github, TriggeredMessaging/pydotmailer

API Version: 0.1
Tested under: Python 2.7

Requires:
    * Python 2.5

Example Usage
------------------
self.dot_mailer = PyDotMailer(api_username = Secrets.api_username, api_password=Secrets.api_password )
dict_result = self.dot_mailer.add_contacts_to_address_book(address_book_id=self.address_book_id, s_contacts='email\n%s\n' % email, wait_to_complete_seconds=20)

More examples can be found in the tests. 

===== Advanced Options =====
SSL support
------------------
SSL is used by default. An optional constructor parameter is available to disable this if required.