pylint-elasticsearch-dsl

pylint plugin for the elasticsearch-dsl package


Install
pip install pylint-elasticsearch-dsl==0.1.0

Documentation

pylint-elasticsearch-dsl

pylint plugin for the elasticsearch-dsl package

This plugin is needed to help pylint understand the types of some objects of the elasticsearch-dsl package.

Currently, this plugin only patches the false positive invalid-unary-operand-type error that is triggered when writing for example:

from elasticsearch_dsl import Q

~Q("exists", field="foo")

See this issue for more details.

Contributing

To work on this project, install the development requirements by running:

make install

The tests can be run with:

make test