This package enables emulation of pytket circuits using the PECOS emulator.


License
Apache-2.0
Install
pip install pytket_pecos==0.1.27

Documentation

pytket-pecos

This package enables emulation of pytket circuits using the PECOS emulator.

Installation

Installation requires Python 3.10, 3.11 or 3.12. Linux, MacOS and Windows are all supported.

From pypi

pip install pytket_pecos

From source

# Clone the pytket-pecos repo:

git clone git@github.com:CQCL/pytket-pecos.git

# Set up the virtual environment

cd pytket-pecos
python -m venv env
. env/bin/activate
pip install -U pip flit wheel

# Install pytket-pecos

flit install

Testing

To run the unit tests:

python -m unittest test.test_emulator