Simple, multilingual natural language tools.


License
Other
Install
pip install simplenlp==1.1.2

Documentation

Simple, multilingual natural language tools.

This package accomplishes many basic NLP tasks without dependencies on NLTK or parsers, for use in projects such as ConceptNet.

Japanese support requires MeCab, a third-party library. More complete analysis is possible if you also install Cabocha and use the language 'ja_cabocha', though many applications will not need it. For installation instructions, see https://github.com/commonsense/simplenlp/raw/master/simplenlp/ja_cabocha/README.txt. If you don't need Cabocha, you only need to install the first two (MeCab and IpaDic).

See http://csc.media.mit.edu/docs for more information.

Authors: Rob Speer, Kenneth Arnold, and Tyson Roberts