This project provides a collection of miscellaneous Python utilities.


License
BSD-3-Clause
Install
pip install smoke-zephyr==2.0.0

Documentation

smoke-zephyr

Python utility collection

Documentation Status Github Issues PyPi Release

Version 2.0 -- From version 2.0 onwards, Python 2.7 is no longer supported. For Python 2.7 support, use the latest 1.x version (v1.4.1).

License

smoke-zephyr is released under the BSD 3-clause license, for more details see the LICENSE file.

Supported Versions

The following version of Python are currently supported:

  • Python 3.4
  • Python 3.5
  • Python 3.6
  • Python 3.7

Code Documentation

smoke-zephyr uses Sphinx for internal code documentation. This documentation can be generated from source with the command sphinx-build docs/source docs/html. The latest documentation is kindly hosted on ReadTheDocs at smoke-zephyr.readthedocs.io.