zipfile-dclimplode

Monkey patch the standard zipfile module to enable DCL Implode support


Keywords
zip, zipfile, ppmd
License
MIT
Install
pip install zipfile-dclimplode==0.0.3.1

Documentation

For zipfile-xz information, see xz branch. For zipfile-isal information, see isal branch. For zipfile-dclimplode information, see dclimplode branch.

zipfile-ppmd

PyPI

Monkey patch the standard zipfile module to enable PPMd support.

Based on zipfile-deflate64 and zipfile-zstandard, which provides similar functionality but for the deflate64 algorithm. Unlike zipfile-deflate64, this package supports both compression and decompression.

Requires pyppmd for ppmd bindings. Note that 0.16.0+ is required, which is not released yet. Please do python3 -m pip install git+https://github.com/miurahr/pyppmd.

Note: if you need Python2, use zipfile39 instead (it is also compatible with Python3).

Installation

pip install zipfile-ppmd

Usage

Anywhere in a Python codebase:

import zipfile_ppmd  # This has the side effect of patching the zipfile module to support PPMd

Alternatively, zipfile_ppmd re-exports the zipfile API, as a convenience:

import zipfile_ppmd as zipfile

zipfile.ZipFile(...)

Compression example:

import zipfile_ppmd as zipfile

zf = zipfile.ZipFile('/tmp/test.zip', 'w', zipfile.ZIP_PPMD, compresslevel=5)
zf.write('large_file.img')