unf_ext 0.0.7.2

Unicode Normalization Form support library for CRuby

Homepage: https://github.com/knu/ruby-unf_ext

Platform: Rubygems

Language: C++

License: MIT

View on registry: https://rubygems.org/gems/unf_ext/versions/0.0.7.2

Documentation: http://www.rubydoc.info/gems/unf_ext/0.0.7.2

Direct download link: https://rubygems.org/downloads/unf_ext-0.0.7.2.gem

Install: gem install unf_ext -v 0.0.7.2


ruby-unf_ext

Synopsis

  • Unicode Normalization Form support library for CRuby

Description

  • Normalizes UTF-8 strings into and from NFC, NFD, NFKC or NFKD

    # For bulk conversion
    normalizer = UNF::Normalizer.new
    a_bunch_of_strings.map! { |string|
      normalizer.normalize(string, :nfc) #=> string in NFC
    }
    
  • Compliant with Unicode 6.0

Requirement

  • Ruby 1.8.7+, 1.9.2+

  • C++ compiler and libstdc++

Installation

gem install unf_ext

Or:

ruby extconf.rb && make && make install

Development Resources

License

Copyright (c) 2010 Takeru Ohta Copyright (c) 2011-2015 Akinori MUSHA

Licensed under the MIT license. See LICENSE for details.

Releases

  • 0.0.7.2 - February 03, 2016 08:50
  • 0.0.7.1 - April 17, 2015 16:36
  • 0.0.7 - April 17, 2015 00:00
  • 0.0.6 - February 16, 2013 10:03
  • 0.0.5 - May 30, 2012 02:22
  • 0.0.4 - December 08, 2011 05:58
  • 0.0.3 - October 24, 2011 19:40

Project Statistics

SourceRank 14
Dependencies 0
Dependent projects 14
Dependent repositories 14.5K
Total releases 7
Latest release
First release
Stars 11
Forks 11
Watchers 3
Contributors 2
Repo Size: 1.8 MB

Top Contributors See all

Akinori MUSHA Vladimir Kochnev

Something wrong with this page? Make a suggestion

Export .ABOUT file for this library

Last synced: 2015-01-28 23:26:28 UTC

Login to resync this project