github.com/RobotsAndPencils/GrandCentralDispatch

GCD for Swift 2 (Linux ready)



Documentation

GrandCentralDispatch

Swift 2.1 Platforms OS X | iOS Cocoapods Compatible Carthage Compatible License MIT Travis codecov.io Slack Status

GrandCentralDispatch is a Grand Central Dispatch wrapper for Swift 2.

Features

  • No Foundation dependency (Linux ready)
  • Queues
  • Semaphore
  • IO Channel

Installation

CocoaPods

CocoaPods is a dependency manager for Cocoa projects. You can install it with the following command:

$ gem install cocoapods

CocoaPods 0.39.0+ is required to build GrandCentralDispatch.

To integrate GrandCentralDispatch into your Xcode project using CocoaPods, specify it in your Podfile:

source 'https://github.com/Zewo/Specs.git'
source 'https://github.com/CocoaPods/Specs.git'
use_frameworks!

pod 'GrandCentralDispatch', '0.1'

Don't forget source 'https://github.com/Zewo/Specs.git'. This is very important. It should always come before the official CocoaPods repo.

Then, run the following command:

$ pod install

Carthage

Carthage is a decentralized dependency manager that automates the process of adding frameworks to your Cocoa application.

You can install Carthage with Homebrew using the following command:

$ brew update
$ brew install carthage

To integrate GrandCentralDispatch into your Xcode project using Carthage, specify it in your Cartfile:

github "Zewo/GrandCentralDispatch" == 0.1

Command Line Application

To use GrandCentralDispatch in a command line application:

Community

Slack

Join us on Slack.

License

GrandCentralDispatch is released under the MIT license. See LICENSE for details.