Dart


Total Packages: 24,863


Popular Dart Packages See more »

sass
A pure JavaScript implementation of Sass.
Latest release 1.71.1 - Updated - 3.74K stars
meta
Annotations used to express developer intentions that can't otherwise be deduced by statically an...
Latest release 1.12.0 - Updated - 9.68K stars
analyzer
This package provides a library that performs static analysis of Dart code.
Latest release 6.4.1 - Updated - 9.68K stars
http
A composable, multi-platform, Future-based API for HTTP requests.
Latest release 1.2.1 - Updated - 983 stars
test
A full featured library for writing and running Dart tests across platforms.
Latest release 1.25.2 - Updated - 484 stars

New Dart Packages See more »

graphify
A data visualization charts library, based on Apache Echarts, able to build advanced charts like ...
Latest release 0.0.1 - Published - 1 stars
payment_card
A custom widget for creating beautiful payment(eg. credit or debit) cards on flutter.
Latest release 0.0.1 - Published - 1 stars
multi_date_picker
This is pub package that lets user pick single or multiple dates and could be used of check-in ch...
Latest release 0.0.1-beta.1 - Published
live_file_publisher
Publish live video streams to RTSP or RTMP servers.
Latest release 0.0.1 - Published
circular_carousel_slider
A circular carousel slider is a widget that displays content in a circular motion, allowing for c...
Latest release 0.0.1 - Published

Updated Dart Packages See more »

empire
A simple yet powerful state management library for Flutter. Keeps your widget build methods clean...
Latest release 1.2.0 - Updated - 9 stars
gql_exec
Basis for GraphQL execution layer to support Link and Client.
Latest release 1.0.1-alpha+1708718049283 - Updated - 261 stars
gql_websocket_link
GQL Websocket Link
Latest release 2.0.2-alpha+1708718049298 - Updated - 261 stars
gql_transform_link
GQL Link to transform Requests and Responses. May be used to update context, document, variables,...
Latest release 1.0.1-alpha+1708718049306 - Updated - 261 stars
gql_http_link
GQL Terminating Link to execute requests via HTTP using JSON.
Latest release 1.0.2-alpha+1708718049313 - Updated - 261 stars

Most Depended upon Dart Packages

sass
A pure JavaScript implementation of Sass.
Latest release 1.71.1 - Updated - 3.74K stars
flutter_lints
Recommended lints for Flutter apps, packages, and plugins to encourage good coding practices.
Latest release 3.0.1 - Updated - 3.83K stars
test
A full featured library for writing and running Dart tests across platforms.
Latest release 1.25.2 - Updated - 484 stars
meta
Annotations used to express developer intentions that can't otherwise be deduced by statically an...
Latest release 1.12.0 - Updated - 9.68K stars
lints
Official Dart lint rules. Defines the 'core' and 'recommended' set of lints suggested by the Dart...
Latest release 3.0.0 - Updated - 94 stars

Top Dart Licenses

MIT 12.6K projects

BSD-3-Clause 4.09K projects

Apache-2.0 1.99K projects

BSD-2-Clause 828 projects

GPL-3.0 457 projects

MPL-2.0 122 projects

Unlicense 80 projects

ISC 68 projects

AGPL-3.0 53 projects

Top Dart Package Managers

Pub 24.5K projects

npm 120 projects

Go 87 projects

Maven 30 projects

Cargo 16 projects

NuGet 16 projects

CocoaPods 15 projects

PyPI 14 projects

Rubygems 3 projects

Bower 2 projects