Stylus mixins and utilities


License
MIT
Install
npm install nib@1.1.2

Contributors

TJ Holowaychuk Sean Lang Roman Komarov Anton Podviaznikov Guillermo Rauch Jurie-Jan Botha Ian Storm Taylor Parallel.li Kevin Decker Jan Buschtöns Jonathan Koch Maxime Janton c4605 Dustan Kasten Tom Stoecklein Vadim K. Pierre-Antoine Delnatte Eli Luberoff Alex Zelensky Mikhail Korepanov Udo Kramer Casey Foster Tõnis Tiigi Jorge Bucaran


See all contributors


Documentation

Build Status

Nib

Stylus mixins, utilities, components, and gradient image generation. Don't forget to check out the documentation.

Installation

$ npm install nib

If the image generation features of Nib are desired, such as generating the linear gradient images, install node-canvas:

$ npm install canvas

JavaScript API

Below is an example of how to utilize nib and stylus with the connect framework (or express).

var connect = require('connect')
  , stylus = require('stylus')
  , nib = require('nib');

var server = connect();

function compile(str, path) {
  return stylus(str)
	.set('filename', path)
	.set('compress', true)
	.use(nib());
}

server.use(stylus.middleware({
	src: __dirname
  , compile: compile
}));

Stylus API

To gain access to everything nib has to offer, simply add:

@import 'nib'

Or you may also pick and choose based on the directory structure in ./lib, for example:

@import 'nib/gradients'
@import 'nib/overflow'
@import 'nib/normalize'

To be continued...

More Information

Testing

You will first need to install the dependencies:

   $ npm install -d

Run the automated test cases:

   $ npm test

For visual testing run the test server:

   $ npm run-script test-server

Then visit localhost:3000 in your browser.

Contributors

I would love more contributors. And if you have helped out, you are awesome! I want to give a huge thanks to these people: