NlpToolkit-NGram-Cy

NGram library


Keywords
good-turing-smoothing, laplace-smoothing, ngram, ngram-language-model, smoothing-methods
License
GPL-3.0
Install
pip install NlpToolkit-NGram-Cy==1.0.6

Documentation

For Developers

You can also see Java, C++, Swift, or C# repository.

Requirements

Python

To check if you have a compatible version of Python installed, use the following command:

python -V

You can find the latest version of Python here.

Git

Install the latest version of Git.

Download Code

In order to work on code, create a fork from GitHub page. Use Git for cloning the code to your local or below line for Ubuntu:

git clone <your-fork-git-link>

A directory called NGram will be created. Or you can use below link for exploring the code:

git clone https://github.com/starlangsoftware/NGram-Py.git

Open project with Pycharm IDE

Steps for opening the cloned project:

  • Start IDE
  • Select File | Open from main menu
  • Choose NGram-PY file
  • Select open as project option
  • Couple of seconds, dependencies will be downloaded.