Backport of the concurrent.futures package from Python 3


License
Python-2.0
Install
pip install futures==3.3.0

Documentation

Build Status

This is a backport of the concurrent.futures standard library module to Python 2.

It does not work on Python 3 due to Python 2 syntax being used in the codebase. Python 3 users should not attempt to install it, since the package is already included in the standard library.

To conditionally require this library only on Python 2, you can do this in your setup.py:

setup(
    ...
    extras_require={
        ':python_version == "2.7"': ['futures']
    }
)

Or, using the newer syntax:

setup(
    ...
    install_requires={
        'futures; python_version == "2.7"'
    }
)

Warning

The ProcessPoolExecutor class has known (unfixable) problems on Python 2 and should not be relied on for mission critical work. Please see Issue 29 and upstream bug report for more details.