globus-search-cli

Globus Search CLI


Keywords
globus, cli, command, line, search
License
Apache-2.0
Install
pip install globus-search-cli==0.4.0

Documentation

https://readthedocs.org/projects/globus-search-cli/badge/?version=latest

Globus Search CLI

A command-line tool for interacting with Globus Search.

Provides the globus-search command.

Note

At a future date, we hope to incorporate this functionality into the globus-cli. At that time, support for this tool will be dropped.

Requirements

You must have Python 3.5+ and pip installed. There are no other requirements.

Install

pip install globus-search-cli

Install for Production Usage

If you plan to use globus-search-cli in a production environment or workflow, it is strongly recommended that you pin the exact version you are using while it is in beta.

For example,

pip install 'globus-search-cli==0.4.0'

Use

globus-search --help

Uninstall

pip uninstall globus-search-cli

Bugs, Feature Requests, and Issues

All issue tracking is done in the open Globus Search CLI issue tracker.